/usr/src/gcc-4.7/debian/patches/svn-class-updates.diff is in gcc-4.7-source 4.7.4-3ubuntu12.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 | # DP: updated class files from the 4.7 branch upto yyyymmdd.
dir=gcc-4_7-branch
dir=/scratch/packages/gcc/svn/gcc-4_7-branch
tag=gcc_4_7_0_release
branch=gcc-4_7-branch
tmplist=files$$
svn diff --summarize \
svn://gcc.gnu.org/svn/gcc/tags/$tag \
svn://gcc.gnu.org/svn/gcc/branches/$branch \
| grep '\.class$' > $tmplist
sed -n '/^[AM].*\.class$/s,.*/'$tag'/\(.*\),\1,p' $tmplist \
> neworchanged.list
sed -n '/^[D].*\.class$/s,.*/'$tag'/\(.*\),\1,p' $tmplist \
> removed.list
sed -n '/^[^ADM].*\.class$/s,.*/'$tag'/\(.*\),\1,p' $tmplist \
> unknown.list
echo "new or changed: $(wc -l neworchanged.list | cut '-d ' -f1), removed $(wc -l removed.list | cut '-d ' -f1): , unknown: $(wc -l unknown.list | cut '-d ' -f1)"
tar -c -J -f java-class-files.tar.xz -C $dir -T neworchanged.list
uuencode java-class-files.tar.xz java-class-files.tar.xz > java-class-files.tar.xz.uue
rm -f $tmplist neworchanged.list removed.list unknown.list
|