/usr/src/gcc-4.7/debian/patches/gdc-4.6.diff is in gcc-4.7-source 4.7.4-3ubuntu12.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 | # DP: Patches the GCC Directory for D.
--- a/src/gcc/cgraph.c 2011-03-04 18:49:23.000000000 +0000
+++ b/src/gcc/cgraph.c 2011-07-09 20:25:16.517533109 +0100
@@ -491,6 +491,7 @@ struct cgraph_node *
cgraph_node (tree decl)
{
struct cgraph_node key, *node, **slot;
+ tree context;
gcc_assert (TREE_CODE (decl) == FUNCTION_DECL);
@@ -512,11 +513,15 @@ cgraph_node (tree decl)
node = cgraph_create_node ();
node->decl = decl;
*slot = node;
- if (DECL_CONTEXT (decl) && TREE_CODE (DECL_CONTEXT (decl)) == FUNCTION_DECL)
+ if (DECL_STATIC_CHAIN (decl))
{
- node->origin = cgraph_node (DECL_CONTEXT (decl));
- node->next_nested = node->origin->nested;
- node->origin->nested = node;
+ context = decl_function_context (decl);
+ if (context)
+ {
+ node->origin = cgraph_node (context);
+ node->next_nested = node->origin->nested;
+ node->origin->nested = node;
+ }
}
if (assembler_name_hash)
{
--- a/src/gcc/config/i386/i386.c 2011-03-04 17:56:39.000000000 +0000
+++ b/src/gcc/config/i386/i386.c 2011-07-24 12:47:54.466177239 +0100
@@ -5358,6 +5358,10 @@ ix86_handle_cconv_attribute (tree *node,
{
error ("fastcall and thiscall attributes are not compatible");
}
+ if (lookup_attribute ("optlink", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("fastcall and optlink attributes are not compatible");
+ }
}
/* Can combine stdcall with fastcall (redundant), regparm and
@@ -5376,6 +5380,10 @@ ix86_handle_cconv_attribute (tree *node,
{
error ("stdcall and thiscall attributes are not compatible");
}
+ if (lookup_attribute ("optlink", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("stdcall and optlink attributes are not compatible");
+ }
}
/* Can combine cdecl with regparm and sseregparm. */
@@ -5393,6 +5401,10 @@ ix86_handle_cconv_attribute (tree *node,
{
error ("cdecl and thiscall attributes are not compatible");
}
+ if (lookup_attribute ("optlink", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("cdecl and optlink attributes are not compatible");
+ }
}
else if (is_attribute_p ("thiscall", name))
{
@@ -5411,6 +5423,31 @@ ix86_handle_cconv_attribute (tree *node,
{
error ("cdecl and thiscall attributes are not compatible");
}
+ if (lookup_attribute ("optlink", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("optlink and thiscall attributes are not compatible");
+ }
+ }
+
+ /* Can combine optlink with regparm and sseregparm. */
+ else if (is_attribute_p ("optlink", name))
+ {
+ if (lookup_attribute ("cdecl", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("optlink and cdecl attributes are not compatible");
+ }
+ if (lookup_attribute ("fastcall", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("optlink and fastcall attributes are not compatible");
+ }
+ if (lookup_attribute ("stdcall", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("optlink and stdcall attributes are not compatible");
+ }
+ if (lookup_attribute ("thiscall", TYPE_ATTRIBUTES (*node)))
+ {
+ error ("optlink and thiscall attributes are not compatible");
+ }
}
/* Can combine sseregparm with all attributes. */
@@ -5644,6 +5681,12 @@ ix86_return_pops_args (tree fundecl, tre
|| lookup_attribute ("thiscall", TYPE_ATTRIBUTES (funtype)))
rtd = 1;
+ /* Optlink functions will pop the stack if floating-point return
+ and if not variable args. */
+ if (lookup_attribute ("optlink", TYPE_ATTRIBUTES (funtype))
+ && FLOAT_MODE_P (TYPE_MODE (TREE_TYPE (funtype))))
+ rtd = 1;
+
if (rtd && ! stdarg_p (funtype))
return size;
}
@@ -5991,6 +6034,11 @@ init_cumulative_args (CUMULATIVE_ARGS *c
}
else
cum->nregs = ix86_function_regparm (fntype, fndecl);
+
+ /* For optlink, last parameter is passed in eax rather than
+ being pushed on the stack. */
+ if (lookup_attribute ("optlink", TYPE_ATTRIBUTES (fntype)))
+ cum->optlink = 1;
}
/* Set up the number of SSE registers used for passing SFmode
@@ -8721,6 +8769,10 @@ ix86_frame_pointer_required (void)
if (crtl->profile && !flag_fentry)
return true;
+ /* Optlink mandates the setting up of ebp, unless 'naked' is used. */
+ if (crtl->args.info.optlink && !cfun->naked)
+ return true;
+
return false;
}
@@ -9366,6 +9418,10 @@ ix86_compute_frame_layout (struct ix86_f
frame->red_zone_size = 0;
frame->stack_pointer_offset -= frame->red_zone_size;
+ if (cfun->naked)
+ /* As above, skip return address. */
+ frame->stack_pointer_offset = UNITS_PER_WORD;
+
/* The SEH frame pointer location is near the bottom of the frame.
This is enforced by the fact that the difference between the
stack pointer and the frame pointer is limited to 240 bytes in
@@ -29731,7 +29787,7 @@ x86_output_mi_thunk (FILE *file,
output_set_got (tmp, NULL_RTX);
xops[1] = tmp;
- output_asm_insn ("mov{l}\t{%0@GOT(%1), %1|%1, %0@GOT[%1]}", xops);
+ output_asm_insn ("mov{l}\t{%a0@GOT(%1), %1|%1, %a0@GOT[%1]}", xops);
output_asm_insn ("jmp\t{*}%1", xops);
}
}
@@ -32553,6 +32609,8 @@ static const struct attribute_spec ix86_
/* Sseregparm attribute says we are using x86_64 calling conventions
for FP arguments. */
{ "sseregparm", 0, 0, false, true, true, ix86_handle_cconv_attribute },
+ /* Optlink attribute says we are using D calling convention */
+ { "optlink", 0, 0, false, true, true, ix86_handle_cconv_attribute },
/* force_align_arg_pointer says this function realigns the stack at entry. */
{ (const char *)&ix86_force_align_arg_pointer_string, 0, 0,
false, true, true, ix86_handle_cconv_attribute },
--- a/src/gcc/config/i386/i386.h 2011-01-14 21:03:22.000000000 +0000
+++ b/src/gcc/config/i386/i386.h 2011-07-09 20:25:16.661533818 +0100
@@ -1498,6 +1498,7 @@ typedef struct ix86_args {
int regno; /* next available register number */
int fastcall; /* fastcall or thiscall calling convention
is used */
+ int optlink; /* optlink calling convention is used */
int sse_words; /* # sse words passed so far */
int sse_nregs; /* # sse registers available for passing */
int warn_avx; /* True when we want to warn about AVX ABI. */
--- a/src/gcc/config/rs6000/rs6000.c 2011-03-15 12:57:37.000000000 +0000
+++ b/src/gcc/config/rs6000/rs6000.c 2011-07-09 20:25:16.721534120 +0100
@@ -22039,6 +22039,7 @@ rs6000_output_function_epilogue (FILE *f
a number, so for now use 9. LTO isn't assigned a number either,
so for now use 0. */
if (! strcmp (language_string, "GNU C")
+ || ! strcmp (language_string, "GNU D")
|| ! strcmp (language_string, "GNU GIMPLE")
|| ! strcmp (language_string, "GNU Go"))
i = 0;
--- a/src/gcc/dojump.c 2010-05-19 21:09:57.000000000 +0100
+++ b/src/gcc/dojump.c 2011-07-12 23:03:55.909624421 +0100
@@ -80,7 +80,8 @@ void
clear_pending_stack_adjust (void)
{
if (optimize > 0
- && (! flag_omit_frame_pointer || cfun->calls_alloca)
+ && ((! flag_omit_frame_pointer && ! cfun->naked)
+ || cfun->calls_alloca)
&& EXIT_IGNORE_STACK)
discard_pending_stack_adjust ();
}
--- a/src/gcc/dwarf2out.c 2011-03-18 16:22:01.000000000 +0000
+++ b/src/gcc/dwarf2out.c 2011-07-09 20:25:16.781534412 +0100
@@ -20069,6 +20069,8 @@ gen_compile_unit_die (const char *filena
language = DW_LANG_C89;
if (strcmp (language_string, "GNU C++") == 0)
language = DW_LANG_C_plus_plus;
+ else if (strcmp (language_string, "GNU D") == 0)
+ language = DW_LANG_D;
else if (strcmp (language_string, "GNU F77") == 0)
language = DW_LANG_Fortran77;
else if (strcmp (language_string, "GNU Pascal") == 0)
@@ -21464,7 +21466,7 @@ dwarf2out_decl (tree decl)
/* For local statics lookup proper context die. */
if (TREE_STATIC (decl) && decl_function_context (decl))
- context_die = lookup_decl_die (DECL_CONTEXT (decl));
+ context_die = lookup_decl_die (decl_function_context (decl));
/* If we are in terse mode, don't generate any DIEs to represent any
variable declarations or definitions. */
--- a/src/gcc/function.c 2011-03-09 20:49:00.000000000 +0000
+++ b/src/gcc/function.c 2011-07-10 18:54:33.562977424 +0100
@@ -3409,7 +3409,8 @@ assign_parms (tree fndecl)
targetm.calls.function_arg_advance (&all.args_so_far, data.promoted_mode,
data.passed_type, data.named_arg);
- assign_parm_adjust_stack_rtl (&data);
+ if (!cfun->naked)
+ assign_parm_adjust_stack_rtl (&data);
if (assign_parm_setup_block_p (&data))
assign_parm_setup_block (&all, parm, &data);
@@ -3426,7 +3427,8 @@ assign_parms (tree fndecl)
/* Output all parameter conversion instructions (possibly including calls)
now that all parameters have been copied out of hard registers. */
- emit_insn (all.first_conversion_insn);
+ if (!cfun->naked)
+ emit_insn (all.first_conversion_insn);
/* Estimate reload stack alignment from scalar return mode. */
if (SUPPORTS_STACK_ALIGNMENT)
@@ -3590,6 +3592,9 @@ gimplify_parameters (void)
VEC(tree, heap) *fnargs;
unsigned i;
+ if (cfun->naked)
+ return NULL;
+
assign_parms_initialize_all (&all);
fnargs = assign_parms_augmented_arg_list (&all);
@@ -5287,6 +5292,9 @@ thread_prologue_and_epilogue_insns (void
edge e;
edge_iterator ei;
+ if (cfun->naked)
+ return;
+
rtl_profile_for_bb (ENTRY_BLOCK_PTR);
inserted = false;
--- a/src/gcc/function.h 2011-01-03 20:52:22.000000000 +0000
+++ b/src/gcc/function.h 2011-07-12 23:04:20.197744890 +0100
@@ -636,6 +636,10 @@ struct GTY(()) function {
adjusts one of its arguments and forwards to another
function. */
unsigned int is_thunk : 1;
+
+ /* Nonzero if no code should be generated for prologues, copying
+ parameters, etc. */
+ unsigned int naked : 1;
};
/* Add the decl D to the local_decls list of FUN. */
--- a/src/gcc/gcc.c 2011-02-23 02:04:43.000000000 +0000
+++ b/src/gcc/gcc.c 2011-07-12 21:55:05.805144355 +0100
@@ -83,6 +83,9 @@ int is_cpp_driver;
/* Flag set to nonzero if an @file argument has been supplied to gcc. */
static bool at_file_supplied;
+/* Flag set by drivers needing Pthreads. */
+int need_pthreads;
+
/* Definition of string containing the arguments given to configure. */
#include "configargs.h"
@@ -373,6 +376,7 @@ or with constant text in a single argume
assembler has done its job.
%D Dump out a -L option for each directory in startfile_prefixes.
If multilib_dir is set, extra entries are generated with it affixed.
+ %N Output the currently selected multilib directory name.
%l process LINK_SPEC as a spec.
%L process LIB_SPEC as a spec.
%G process LIBGCC_SPEC as a spec.
@@ -3925,6 +3929,17 @@ process_command (unsigned int decoded_op
add_infile ("help-dummy", "c");
}
+ if (need_pthreads)
+ {
+ switches[n_switches].part1 = "pthread";
+ switches[n_switches].args = 0;
+ switches[n_switches].live_cond = 0;
+ /* Do not print an error if there is not expansion for -pthread. */
+ switches[n_switches].validated = 1;
+ switches[n_switches].ordering = 0;
+ n_switches++;
+ }
+
alloc_switch ();
switches[n_switches].part1 = 0;
alloc_infile ();
@@ -5095,6 +5110,17 @@ do_spec_1 (const char *spec, int inswitc
return value;
break;
+ case 'N':
+ if (multilib_dir)
+ {
+ arg_going = 1;
+ obstack_grow (&obstack, "-fmultilib-dir=",
+ strlen ("-fmultilib-dir="));
+ obstack_grow (&obstack, multilib_dir,
+ strlen (multilib_dir));
+ }
+ break;
+
/* Here we define characters other than letters and digits. */
case '{':
--- a/src/gcc/ira.c 2011-03-08 15:51:12.000000000 +0000
+++ b/src/gcc/ira.c 2011-07-12 23:04:12.433706377 +0100
@@ -1341,7 +1341,7 @@ ira_setup_eliminable_regset (void)
case. At some point, we should improve this by emitting the
sp-adjusting insns for this case. */
int need_fp
- = (! flag_omit_frame_pointer
+ = ((! flag_omit_frame_pointer && ! cfun->naked)
|| (cfun->calls_alloca && EXIT_IGNORE_STACK)
/* We need the frame pointer to catch stack overflow exceptions
if the stack pointer is moving. */
--- a/src/gcc/tree-sra.c 2011-02-17 16:18:24.000000000 +0000
+++ b/src/gcc/tree-sra.c 2011-07-09 20:25:16.941535211 +0100
@@ -1533,6 +1533,8 @@ is_va_list_type (tree type)
/* The very first phase of intraprocedural SRA. It marks in candidate_bitmap
those with type which is suitable for scalarization. */
+/* FIXME: Should we do something here for GDC? */
+
static bool
find_var_candidates (void)
{
|