/usr/src/gcc-4.7/debian/patches/gcc-driver-extra-langs.diff is in gcc-4.7-source 4.7.4-3ubuntu12.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 | # DP: Add options and specs for languages that are not built from a source
# DP: (but built from separate sources).
---
gcc/Makefile.in | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
Index: b/src/gcc/Makefile.in
===================================================================
--- a/src/gcc/Makefile.in
+++ b/src/gcc/Makefile.in
@@ -531,8 +531,8 @@
dg-torture.exp,ieee.exp \
vect.exp,guality.exp,unsorted.exp \
struct-layout-1.exp,stackalign.exp,$(dg_target_exps)
-lang_opt_files=@lang_opt_files@ $(srcdir)/c-family/c.opt $(srcdir)/common.opt
-lang_specs_files=@lang_specs_files@
+lang_opt_files=$(sort @lang_opt_files@ $(srcdir)/c-family/c.opt $(srcdir)/common.opt $(foreach lang,$(subst ada,ada/gcc-interface,$(debian_extra_langs)),$(srcdir)/$(lang)/lang.opt))
+lang_specs_files=$(sort @lang_specs_files@ $(foreach lang,$(subst ada,ada/gcc-interface,$(debian_extra_langs)),$(srcdir)/$(lang)/lang-specs.h))
lang_tree_files=@lang_tree_files@
target_cpu_default=@target_cpu_default@
OBJC_BOEHM_GC=@objc_boehm_gc@
|