/usr/src/gcc-4.7/debian/patches/cross-no-locale-include.diff is in gcc-4.7-source 4.7.4-3ubuntu12.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 | # DP: Don't add /usr/local/include for cross compilers. Assume that
# DP: /usr/include is ready for multiarch, but not /usr/local/include.
--- a/src/gcc/cppdefault.c
+++ b/src/gcc/cppdefault.c
@@ -66,8 +66,11 @@
#ifdef LOCAL_INCLUDE_DIR
/* /usr/local/include comes before the fixincluded header files. */
{ LOCAL_INCLUDE_DIR, 0, 0, 1, 1, 2 },
+#if 0
+ /* Unsafe to assume that /usr/local/include is ready for multiarch. */
{ LOCAL_INCLUDE_DIR, 0, 0, 1, 1, 0 },
#endif
+#endif
#ifdef PREFIX_INCLUDE_DIR
{ PREFIX_INCLUDE_DIR, 0, 0, 1, 0, 0 },
#endif
|