/usr/src/gcc-4.7/debian/patches/boehm-gc-getnprocs.diff is in gcc-4.7-source 4.7.4-3ubuntu12.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 | # DP: boehm-gc/pthread_support.c (GC_get_nprocs): Use sysconf as fallback.
---
boehm-gc/pthread_support.c | 3 ++-
1 files changed, 2 insertions(+), 1 deletions(-)
--- a/src/boehm-gc/pthread_support.c
+++ b/src/boehm-gc/pthread_support.c
@@ -724,7 +724,8 @@
f = open("/proc/stat", O_RDONLY);
if (f < 0 || (len = STAT_READ(f, stat_buf, STAT_BUF_SIZE)) < 100) {
WARN("Couldn't read /proc/stat\n", 0);
- return -1;
+ /* Fallback to sysconf after the warning */
+ return sysconf(_SC_NPROCESSORS_ONLN);
}
for (i = 0; i < len - 100; ++i) {
if (stat_buf[i] == '\n' && stat_buf[i+1] == 'c'
|