/usr/src/gcc-4.7/debian/patches/ada-gcc-name.diff is in gcc-4.7-source 4.7.4-3ubuntu12.
This file is owned by root:root, with mode 0o644.
The actual contents of the file can be viewed below.
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 | # DP: use gcc-4.7 instead of gcc as the command name.
Index: b/src/gcc/ada/comperr.adb
===================================================================
--- a/src/gcc/ada/comperr.adb
+++ b/src/gcc/ada/comperr.adb
@@ -356,7 +356,7 @@
End_Line;
Write_Str
- ("| Include the exact gcc or gnatmake command " &
+ ("| Include the exact gcc-4.7 or gnatmake command " &
"that you entered.");
End_Line;
Index: b/src/gcc/ada/gnatlink.adb
===================================================================
--- a/src/gcc/ada/gnatlink.adb
+++ b/src/gcc/ada/gnatlink.adb
@@ -137,7 +137,7 @@
-- This table collects the arguments to be passed to compile the binder
-- generated file.
- Gcc : String_Access := Program_Name ("gcc", "gnatlink");
+ Gcc : String_Access := Program_Name ("gcc-4.7", "gnatlink");
Read_Mode : constant String := "r" & ASCII.NUL;
@@ -1411,7 +1411,8 @@
end if;
Write_Line (" --GCC=comp Use comp as the compiler");
- Write_Line (" --LINK=nam Use 'nam' for the linking rather than 'gcc'");
+ Write_Line (" --LINK=nam Use 'nam' for the linking rather " &
+ "than 'gcc-4.7'");
Write_Eol;
Write_Line (" [non-Ada-objects] list of non Ada object files");
Write_Line (" [linker-options] other options for the linker");
Index: b/src/gcc/ada/make.adb
===================================================================
--- a/src/gcc/ada/make.adb
+++ b/src/gcc/ada/make.adb
@@ -670,7 +670,7 @@
-- Compiler, Binder & Linker Data and Subprograms --
----------------------------------------------------
- Gcc : String_Access := Program_Name ("gcc", "gnatmake");
+ Gcc : String_Access := Program_Name ("gcc-4.7", "gnatmake");
Gnatbind : String_Access := Program_Name ("gnatbind", "gnatmake");
Gnatlink : String_Access := Program_Name ("gnatlink", "gnatmake");
-- Default compiler, binder, linker programs
Index: b/src/gcc/ada/gnatchop.adb
===================================================================
--- a/src/gcc/ada/gnatchop.adb
+++ b/src/gcc/ada/gnatchop.adb
@@ -44,7 +44,7 @@
Config_File_Name : constant String_Access := new String'("gnat.adc");
-- The name of the file holding the GNAT configuration pragmas
- Gcc : String_Access := new String'("gcc");
+ Gcc : String_Access := new String'("gcc-4.7");
-- May be modified by switch --GCC=
Gcc_Set : Boolean := False;
Index: b/src/gcc/ada/mdll-utl.adb
===================================================================
--- a/src/gcc/ada/mdll-utl.adb
+++ b/src/gcc/ada/mdll-utl.adb
@@ -39,7 +39,7 @@
Dlltool_Name : constant String := "dlltool";
Dlltool_Exec : OS_Lib.String_Access;
- Gcc_Name : constant String := "gcc";
+ Gcc_Name : constant String := "gcc-4.7";
Gcc_Exec : OS_Lib.String_Access;
Gnatbind_Name : constant String := "gnatbind";
@@ -212,7 +212,7 @@
end;
end if;
- Print_Command ("gcc", Arguments (1 .. A));
+ Print_Command ("gcc-4.7", Arguments (1 .. A));
OS_Lib.Spawn (Gcc_Exec.all, Arguments (1 .. A), Success);
Index: b/src/gcc/ada/mlib-utl.adb
===================================================================
--- a/src/gcc/ada/mlib-utl.adb
+++ b/src/gcc/ada/mlib-utl.adb
@@ -412,7 +412,7 @@
if Driver_Name = No_Name then
if Gcc_Exec = null then
if Gcc_Name = null then
- Gcc_Name := Osint.Program_Name ("gcc", "gnatmake");
+ Gcc_Name := Osint.Program_Name ("gcc-4.7", "gnatmake");
end if;
Gcc_Exec := Locate_Exec_On_Path (Gcc_Name.all);
Index: b/src/gcc/ada/prj-makr.adb
===================================================================
--- a/src/gcc/ada/prj-makr.adb
+++ b/src/gcc/ada/prj-makr.adb
@@ -109,7 +109,7 @@
procedure Dup2 (Old_Fd, New_Fd : File_Descriptor);
- Gcc : constant String := "gcc";
+ Gcc : constant String := "gcc-4.7";
Gcc_Path : String_Access := null;
Non_Empty_Node : constant Project_Node_Id := 1;
|